December 12, 2010

kryptobs2000 kryptobs2000
Lab Rat
5 posts

When running make I get an error saying I’m missing libgmp-10.dll.

 

I’m pretty new to C++ so I’m not sure if I’m missing something obvious or not, I’m not used to compiled languages. I can compile the program and run it file by just invoking g++ directly, but if I do it the way you’re supposed to, qmake/make, I get the above error. libgmp-10.dll is on my system, and it’s on my path. I’m guessing it’s looking for it somewhere other than the path env variable, but I don’t know where and google, nor the forum search, has turned up anything. Thanks.

13 replies

December 12, 2010

Bradley Bradley
Lab Rat
314 posts

Dependancy Walker [dependencywalker.com] is a tool that can help you determine what DLL problems might be caused by.

 Signature 

Nokia Certified Qt Specialist.

December 12, 2010

kryptobs2000 kryptobs2000
Lab Rat
5 posts

I don’t know if I’m understanding this right, but this is the report:

Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module.
Error: Modules with different CPU types were found.
Warning: At least one delay-load dependency module was not found.
Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

And it lists IESHIMS.DLL as missing, if I double click it it just says ‘D:\Qt\2010.05\qt\bin\IESHIMS.DLL was not found.’

So I found that and copied it in there, but I’m still getting the same issue and now this is my log report:

Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module.
Error: Modules with different CPU types were found.
Warning: At least one module has an unresolved import due to a missing export function in a delay-load dependent module.

The only dll I see listed that is x86 is the one I just copied in there, the rest are all x86_64. I don’t have a clue how that works though because qmake is 32-bit? Maybe it doesn’t. The other warning and error message are complete gibberish to me.

December 12, 2010

Bradley Bradley
Lab Rat
314 posts

It doesn’t matter that qmake is 32-bit. It may matter whether the application is 32 or 64-bit. You can’t mix the two. A 64-bit application won’t load a 32-bit library. For example, if the application is 64-bit, but the libgmp-10.dll is 32-bit, it won’t see it as valid and will say it is missing.

There can be errors reported even for a properly working application, and sometimes missing DLLs are ok because they never need to be loaded (IESHIMS.DLL is one of them). You want to look for information about the libgmp-10.dll. What does it report for the location of the libgmp-10.dll?

 Signature 

Nokia Certified Qt Specialist.

December 12, 2010

kryptobs2000 kryptobs2000
Lab Rat
5 posts

When running depwalker on qmake I don’t even see it listing libgmp-10.dll. I don’t see it loading any libraries that are outside the system32 directory except for 2 or 3 which still seem to be included w/Windows and are located somewhere within C:\Windows. Any idea why this would be?

December 12, 2010

Bradley Bradley
Lab Rat
314 posts

You are using the Qt SDK 2010.05, right? Are you running “make.exe” or “mingw32-make.exe” from the Qt command prompt? Could there be multiple make executables in your path?

 Signature 

Nokia Certified Qt Specialist.

December 12, 2010

kryptobs2000 kryptobs2000
Lab Rat
5 posts

I am running just make.exe, but apparently it should be mingw32-make because I am no longer getting errors : ). You are the man. So this is an unrelated question, but I just assumed compiling it with qmake might resolve this, but how do you suppress the console window from opening in Windows when starting the application through explorer? I’m guessing this is a C++ problem and completely unrelated to Qt, I hope you don’t mind me asking out of place.

December 12, 2010

Bradley Bradley
Lab Rat
314 posts
kryptobs2000 wrote:
So this is an unrelated question, but I just assumed compiling it with qmake might resolve this, but how do you suppress the console window from opening in Windows when starting the application through explorer? I’m guessing this is a C++ problem and completely unrelated to Qt, I hope you don’t mind me asking out of place.

I don’t mind, but generally for the forum system to work best a new post should be created. The issue you are seeing with the console window is often caused by having “CONFIG += console” in the .pro file of the project. This is a useful setting if you want to display messages with standard output or error streams (or use qDebug()), but for those messages Windows must open the console window.

 Signature 

Nokia Certified Qt Specialist.

December 12, 2010

kryptobs2000 kryptobs2000
Lab Rat
5 posts

Awesome, thanks so much man, you made my night. I was starting to get pretty frustrated there for a second, but thankfully just put it aside and asked for help instead :P.

December 12, 2010

Mattias Cibien Mattias Cibien
Lab Rat
66 posts

Make.exe is different from the make.bat present in the Qt bin directory. The first one is MSYS make (or even Cygwin or GnuWin32 make but it has minor probability) which is incopatible with Qt. Are you runnning make from MSYS command prompt?

 Signature 

http://mattias-cibien.co.cc
- Prepare for Qt consequences.

December 12, 2010

Smar Smar
Lab Rat
269 posts

Indeed, this make.exe shouldn’t be present unless you’ve installed mingw by yourself and hence the make…

December 12, 2010

kryptobs2000 kryptobs2000
Lab Rat
5 posts

Yeah, that’s where it came from then. I think I may even have two copies of mingw sitting around, probably not the best idea (though only 1 is on the path I believe). So should I uninstall mingw? I didn’t think Qt came with mingw, which I take it you’re implying should have been installed for me?

December 12, 2010

Smar Smar
Lab Rat
269 posts

For me, as I need to compile stuff more closely related to Qt, I’ve come into solution that I just build Qt by myself on Windows, and just use that qtvars.bat script as base for setting the instance I need to. (found from binary releases)

This allows me to have separate installations of Qt without actually conflicting with each other, and same goes for mingw versions, and such.

I don’t know if those SDK thingys messes with PATH, but I think it’s better to leave it alone unless you are 100% positive you won’t ever need any other Qt version than this single one. It just makes stuff confusing and very error prone.

December 12, 2010

Bradley Bradley
Lab Rat
314 posts
kryptobs2000 wrote:
Yeah, that’s where it came from then. I think I may even have two copies of mingw sitting around, probably not the best idea (though only 1 is on the path I believe). So should I uninstall mingw? I didn’t think Qt came with mingw, which I take it you’re implying should have been installed for me?

The Qt SDK comes with mingw. The binary Qt distribution does not.

 Signature 

Nokia Certified Qt Specialist.

 
  ‹‹ Qt/MeeGo/etc. repository      Qt 4.7.1 Symbian Development on Linux ››

You must log in to post a reply. Not a member yet? Register here!