March 22, 2012

Cmnn Cmnn
Lab Rat
6 posts

[solved] cannot get Qt creator start?

 

I have tried to install and uninstall QT SDK for at least 10times, but it still does not run on my laptop. My laptop is SONY VAIO F: QC corei7 1.73GHz, 4GB RAM, NVIDIA GT425M 1GB, and it is running Windows 7. The program installs successful, but it take about 10 minutes to start the program. However, if I start to write a program, it will stop automatically. If I open the program in safe mode, it will run normally. Anybody have this problem? Please help me. I take a C++ this semester and the exam will be giving soon. I hope the problem will be solved so I can practice at home. Thanks

14 replies

March 22, 2012

koahnig koahnig
Area 51 Engineer
2880 posts

welcome to devnet

This sounds odd. For helping you one needs to know the source and version of the Qt SDK you installed. Did you install the most recent one from here [qt.nokia.com] ?
Did you use the online or offline installer?
Did use the default setup or some selections?

March 22, 2012

Tobias Hunger Tobias Hunger
Area 51 Engineer
3383 posts

I have a bug report about strange creator issues with Sony computers on windows… it seems that Qt Creator does not at all like to have “\” and “C:\” in the path which some Sony software seems to put there.

Could you please verify that this is not the case for you?

PS: This is the bug report: https://bugreports.qt-project.org/browse/QTCREATORBUG-6501

March 22, 2012

Tobias Hunger Tobias Hunger
Area 51 Engineer
3383 posts

Just squashed that bug in the 2.5 branch of Qt Creator.

March 22, 2012

Cmnn Cmnn
Lab Rat
6 posts

I down and install both online and offline “Qt SDK 1.2” which is the most recent one from qt.nokia.com, but it did not work. Then I downloaded the Qt SDK 1.1.2, but it still did not work. Now I found out the way to fix it. If I turn off the Wifi before I start the program, it will run normally. After that I can turn on the wifi and still use the Qt creator. Wondering why this happens?

March 23, 2012

Tobias Hunger Tobias Hunger
Area 51 Engineer
3383 posts

Did you check the PATH as I suggested yesterday?

With ‘\’ in the path creator used to trigger windows to look up a lot of network drives (until yesterday)… so that would explain why stuff works better for you with wifi turned of.

March 24, 2012

Cmnn Cmnn
Lab Rat
6 posts

Can you tell me how to set up the PATH??

Tobias Hunger wrote:
Did you check the PATH as I suggested yesterday?

With ‘\’ in the path creator used to trigger windows to look up a lot of network drives (until yesterday)… so that would explain why stuff works better for you with wifi turned of.

March 24, 2012

Tobias Hunger Tobias Hunger
Area 51 Engineer
3383 posts

Google [google.com] has the necessary instructions.

March 26, 2012

mzimmers mzimmers
Lab Rat
529 posts

Specifically, this is a good tutorial:

How to set environment variables in Windows 7 [itechtalk.com]

If your variable has gotten kind of long, it’s inconvenient to edit in the line editor provided by Windows, so I copy the string to something like WordPad and edit it there, and then paste it back into the line editor.

March 27, 2012

Cmnn Cmnn
Lab Rat
6 posts

Thanks for all the help. I actually don’t know what I have to put in the PATH. I’ll ask my instructor or my friends tomorrow.

March 27, 2012

mzimmers mzimmers
Lab Rat
529 posts

If I’m understanding the comments above, your PATH variable probably contains the right items, but Qt is getting confused by the “\” path delimiters. If you replace every occurrence of “\” with “/” you might get some different results. It’s a quick fix to try, anyway.

March 27, 2012

Cmnn Cmnn
Lab Rat
6 posts

I replaced all the “\” with “/”, but Qt still does not run. I will have to turn off wifi if I want to use Qt.

March 27, 2012

Tobias Hunger Tobias Hunger
Area 51 Engineer
3383 posts

No, PATH is a variable handled by windows and it needs to have ‘\’ in it. Do not replace ‘\’ with ‘/’ everywhere!

There was a problem in Qt Creator that made it handle a entry in PATH containing only a backslash incorrectly. If you have an “\” as one element in your PATH then the startup is slow. Please make sure PATH does not start with “\;” as the very first characters, does not end with “;\” as the very last characters and does not contain “;\;” in all the other places. Either remove this part completely or replace it with “C:\” (plus ‘;’ in front/after it, depending on position in the PATH string).

So far all people running into this issue were using Sony VAIO laptops, so most likely some utility specific to this series of laptops adds “\” as one directory to the PATH.

March 27, 2012

Cmnn Cmnn
Lab Rat
6 posts

Thanks. I did it. now I can run Qt without turn off the wifi :))

March 27, 2012

Tobias Hunger Tobias Hunger
Area 51 Engineer
3383 posts

Great! Please mark this thread as solved then by prepending “[solved]” to the title:-)

 
  ‹‹ Qt Creator 2.4.1 problem with fakevim      Qt5 wrong mkspec used in QtCreator ››

You must log in to post a reply. Not a member yet? Register here!