English Русский French [qt-devnet.developpez.com]

Qt Visual Studio Add-in

Getting the source

The source code of the add-in is hosted on gitorious at http://qt.gitorious.org/qt-labs/vstools

To create a repository clone, execute the following command:

  1. git clone git://gitorious.org/qt-labs/vstools.git

Instructions for Qt 5.x

As the addin is a Qt app itself, make sure that you have the following software installed:

  • Visual Studio 2008+
  • Perl
  • Qt 5.0+

These instructions refer to Visual Studio 2012. Replace any references to VS2012 with the appropriate file for your VS version (2008, 2010 and 2012 supported).

Building the addin

Open a command shell with a Qt build environment (Visual Studio built-in prompt configured with Qt in appropriate environment variables, 32 or 64-bit) and cd into your add-in source directory.

Execute the following commands:

  1. cd Qt4VS2003
  2. createUserFiles.bat

This sets up reference paths and debug settings.

  1. cd ..\tools\qmakefilereader
  2. qmake
  3. nmake
  4. cd ..\qtappwrapper
  5. devenv qt5appwrapper2012.sln /useenv /Build release
  6. cd ..
  7. qmake -r
  8. nmake

This builds the external QRC editor which is launched from within Visual Studio.

At this point, the addin can be built. Open Qt4VS2003\Qt5VSAddin2012.sln as an administrator (the build will fail if you don’t), and build the entire solution.

Installation

Open the Qt4VS2003\Qt4VSAddin folder, and copy Qt5VSAddin.AddIn and the Release directory to your VS Addins folder – by default this is “%USERPROFILE%\Documents\Visual Studio 2012\Addins”, but this can be changed under Tools->Options->Environment->Add-in Security. Rename Release to something meaningful (like Qt5VSAddin, since it goes with the addin).

Open Qt5VSAddin.AddIn in your favorite text editor, and find the Version tag. Change it to the version appropriate for your VS version – 2008 is 9.0, 2010 is 10.0, and 2012 is 11.0. Find the Assembly tag and change it to reflect the location of the Qt5VSAddin.dll file within the binary folder, i.e. Qt5VSAddin\Qt5VSAddin.dll.

Go back to Visual Studio, and open Tools->Add-in Manager. Select the addin and restart VS. You should now have a QT5 menu, to the right of VIEW.

Configuration

You should probably configure the addin for your Qt installation. Open QT5->Qt options, and add any versions of Qt you have installed. The rest of the options should be fine for normal use.

Build Instructions for Qt 4.x

Make sure that you have the following software installed:

  • Visual Studio 2005 or above
  • Perl
  • Qt 4.7.0 or newer

Open a command shell with a Qt build environment (Visual Studio build, 32 bit) and cd into your add-in source directory.

Execute the following commands:

  1. cd Qt4VS2003
  2. createUserFiles.cmd

This sets up reference paths and debug settings.

  1. cd ComWrappers\qmakewrapper
  2. qmake
  3. nmake
  4. cd ..\..\tools\qtappwrapper
  5. devenv qtappwrapper2008.sln /useenv /Build release

Adjust the number in qtappwrapper2008.sln according to the VS version you’re using.
Duplicates of the addin’s project files exist for every supported Visual Studio version.

  1. cd ..
  2. qmake -r
  3. nmake

This builds the external QRC editor which is launched from within Visual Studio.
Now we’re ready to open the main solution which contains the actual add-in.

  1. start Qt4VS2003\Qt4VSAddin2008.sln

Now you should be able to build the solution.
Before trying to run your freshly built add-in, read the next section.

Running and Debugging

To run and debug the development version of the Qt Visual Studio Add-in we need to do a little
setup work once again. Note that you can have the Add-in’s release version installed.
You can switch between these two installations as you will see soon.

Install the Add-in’s Description File

Open the directory where your personal Visual Studio settings are stored. This is usually
something like “USERPROFILE\Documents\Visual Studio 2008”.
We’ll just use that directory for illustration. Also, we’ll assume that the
add-in’s repository is located in c:\dev\qtvstools.
Execute the following commands:

  1. cd "%USERPROFILE%\Documents\Visual Studio 2008"
  2. md Addins
  3. cd Addins
  4. copy c:\dev\qtvstools\Qt4VS2003\Qt4VSAddin\Qt4VSAddin.AddIn
.

Qt4VSAddin.AddIn is the add-in’s description file and Visual Studio can now find it.
For other Visual Studio versions than 2008 you must adjust the Version tag in the
Qt4VSAddin.Addin file.

Your installed release version of the add-in is now turned off and cannot be loaded into
Visual Studio anymore. To restore the old state, rename the file extension of Qt4VSAddin.AddIn
to some bogus value like Qt4VSAddin.AddIn.foo. This ensures that it will be ignored by Visual
Studio and the original add-in will be loaded.

Run the Add-in’s Development Version

Now that the .Addin file is in place, we’re ready to try out the development version of the
add-in. Open the solution file (e.g. Qt4VSAddin2008.sln) and press F5.

Another instance of Visual Studio is started. We will call this instance VS2 and the Visual
Studio Instance where the add-in’s solution is loaded VS1.

The add-in is not yet loaded in VS2. To load it, select “Tools/Add-in Manager…” click the
first checkbox in the “Qt4 Add-in Development Version” line and press OK.
Now you should have a “Qt” menu entry in the menubar of Visual Studio which means that the
add-in has been successfully loaded.

In VS1 you can set breakpoints and do all the debugging you need. In VS2 you’re controlling
the add-in.

Categories: