September 19, 2011

groz groz
Lab Rat
1 posts

Need help checking out latest QtQuick

 

I’ve been reading about the new stuff coming to QtQuick, particularly the scene graph stuff, and wanted to check it out. Unfortunately, I can’t seem to find a recent guide as to how this is done. The majority of what I have found points to outdated repositories or the steps simply don’t work.

Can anyone provide instructions (or point me in the right direction) to checkout QT5 with the latest QtQuick 2 and scene graph builds?

I’ve tried following this: http://developer.qt.nokia.com/wiki/Building_Qt_5_from_Git

..but it doesn’t bring in QtQuick 2.0

I’ve also done: git clone git://gitorious.org/+qt-developers/qt/qtdeclarative-staging.git

.. but that doesn’t provide the whole tree and I’m not sure how to combine the two (I have very little experience with git in case that wasn’t obvious)

Thanks for any tips you can provide.

1 reply

September 21, 2011

groz groz
Lab Rat
1 posts

An update to my own post.

After some experimenting, I may have come up with the solution:

  1. git clone git://gitorious.org/+qt-developers/qt/qt5-staging.git
  2. cd qt5-staging
  3. ./init-repository --no-webkit
  4. qtreptools/bin/qt5_tool -s qtdeclarative
  5. cd qtdeclarative
  6. git checkout -b qtquick2-stable staging/qtquick2-stable
  7. cd ..
  8. ./configure -nomake tests -prefix $PWD/qtbase -opensource -confirm-license
  9. make module-qtdeclarative

The ‘—no-webkit’ on the ‘init-repository’ step is to avoid the multi-gig webkit download. The ‘-nomake tests’ on the ‘configure’ step is to get around some problems I had when building the tests.

I was able to get this to build on Linux cleanly and run the ‘qmlscene’ tool and load up a QtQuick 2.0 QML file. Didn’t look great (I suspect because I don’t have acceleration enabled on this particular VM) but at least it compiled cleanly.

My next step is to try the build on Windows with MinGW. Will see how that goes.

EDIT: I went to build this on another system and discovered a few dependencies you might run into: libxext-dev and libgl1-mesa-dev

 
  ‹‹ This Qt version is not compatible to your current Visual Studio???      Fail to install 4.7.4 using Qt Libraries ››

You must log in to post a reply. Not a member yet? Register here!