August 21, 2011

DeathByNukes DeathByNukes
Lab Rat
2 posts

First Time Installation of Qt Creator Fails to Build With Defaults

 

Installed Qt SDK, fired up Creator, opened an example, clicked ok yes default etc, and hit F5. Result:

After minor poking around I see it’s defaulted to building with the oldest installation of MSVC it could find on my system, 2003.
Set it to Debug mode MSVC 2008

and it builds but cannot debug:

Some things in the options:

I have VS 2003 2005 2008 and 2010 installed.

So apparently Qt Creator doesn’t like my system. Any advice? Is it even worth me trying to fix this rather than using Qt integration in Visual Studio?

[EDIT: fixed image links, Volker]

5 replies

August 22, 2011

koahnig koahnig
Gene Splicer
2906 posts

Welcome to the forum

Just a formatting comment. When you use for your links to the pictures the formatting button left to links, all your pictures will be shown immediately in the browser.

Please edit your post. Apparently, you can add single character (exclamation mark) at the begin and end of your links plus an alternate name in round parentesis. However, using the formatting button is probably easier.

August 23, 2011

koahnig koahnig
Gene Splicer
2906 posts

I am using msvc2005 on a win7 system with vsaddin and it works.

Based on my preference I would recommend to use Qt in a consistent system. Either completely visual studio or completely Qt Creator with mingw. Especially for your case this might solve the problems.

One thing you should bear in mind so when using visual studio it is more comfortable with vsaddin. In turnaround this addin requires a licensed version allowing addins. With the different express versions of vs you cannot do this.

If you still like to use the creator with ms compiler, you should have only one ms compiler installed. It could be that creator does somehow mix the different versions.

August 24, 2011

Tobias Hunger Tobias Hunger
Robot Herder
3387 posts

It would help to know which version of Qt Creator you are using:-)

The first issue should be fixed in the up-coming Qt Creator 2.3: That will only offer MSVC tool chains that actually match up with the Qt version used.

The second issue is most likely caused by the microsoft debugging tools being unavailable. Did you install those? They are part of the newer windows SDKs but you used to have to install them separately.

koahnig: Qt Creator works fine for me with the microsoft compilers. Those are no reason to use visual studio;-)

August 25, 2011

DeathByNukes DeathByNukes
Lab Rat
2 posts

I’m using 2.2.1. Guess I’ll keep an eye on that new version.

For the debugging issue, how would a new user normally learn of that dependency? (what did I miss?)
Visual Studio always comes with windows.h and such, so I’ve never had a reason to get the Windows SDK before.

August 25, 2011

Tobias Hunger Tobias Hunger
Robot Herder
3387 posts

I do think we mention the need to have the debugging tools installed in the installation as well as the documentation.

 
  ‹‹ Error when debugging in QtCreator with Visual Studio compiler - QtCore4d.dll missing manifest      Proper etiquette/procedure for querying bug status? ››

You must log in to post a reply. Not a member yet? Register here!