Need help compiling Qt for embedded device (i.mx51 evk)

Page  
2

February 8, 2011

ngrosjean ngrosjean
Lab Rat
30 posts

Hi!

I suppose you have these glib-2.0 install, haven’t you? (try a “locate glib-2.0” perhaps).

February 8, 2011

almagest almagest
Lab Rat
36 posts

ngrosjean gave a good tip.

Also, sanjay1758, please dont post multiple identical posts on the same board.
It only creates confusion. Your other thread [developer.qt.nokia.com]

—————-

Hello.

When you try to compile for the target platform you have to point Qt toward the libraries compiled for that system. It is apparent that you miss the file libglib-2.0.so , either because the folder provided in qmake.conf is wrong or because the file simply isnt there. Obviously you cannot provide a path to your laptop/workstations version of these libraries to solve the issue.

If you use LTIB when setting up the image to be used on the card, look at the second link. It specifies that you use glib2.0 when you compile qt.

Regarding opengl, es2, tslib;
Tslib can be compiled from source (i did myself) to solve this issue.
You can also probably get away by copying the gl,es2 etc files from a precompiled image.
I have a Freescale i.MX51 EVK card, and downloaded a precompiled image from their website.
It contained all the files i needed to get these systems up and running.

Most of the questions related to LTIB (ubuntu) can be seen here;
Builing LTIB on Ubuntu 10.04 [imxcommunity.org]

As for compiling Qt for the Imx.51 EVK, look at this;
All Boards Qt iMXwiki [imxdev.org]

Best regards
almagest

September 14, 2011

raikiri raikiri
Lab Rat
1 posts

check the configure scripts. mostly it is failing trying to make sample opengl file in src/config.tests/unix/opengles* , where * is 1 or 2 depending on the version you are compiling. cd to the directory and do a make.
This is auto generated make file. If it fails, you will get the opengl configuration error while doing a configure also. Try setting right values in the make file. If you are able to build this, set the same values in qmake.conf.

November 14, 2013

dreamerindia dreamerindia
Lab Rat
128 posts

Hi I tried to cross compile qt-everywhere-opensource-src-4.6.1 with openGL es2 support.

Details:
Host:Ubuntu 10.04.4 LTS
Target:ARM Cortex A8 (Freescale i.MX51 Processor)
Target Linux:linux-2.6.31.
Qt Version:4.6.1

Steps i did are,

1.downloaded qt-everywhere-opensource-src-4.6.1.tar.gz from ftp://ftp.qt.nokia.com/qt/source/ [ftp.qt.nokia.com]
2.Copied mkspecs for arm-cortex_a8-linux-gnueabi-g++ and modified its qmake.conf as given – https://dl.dropboxusercontent.com/u/12382973/linux-g++-mx5x/qmake.conf [dl.dropboxusercontent.com] . 3.then configured as,

  1.     ./configure -arch arm -xplatform linux-g++-mx5x -release -prefix / -multimedia -qt-gfx-linuxfb -qt-kbd-tty -little-endian -host-little-endian -fontconfig -sm -opengl es2

And now i got the problem it shows,
“The EGL functionality test failed!
EGL is required for OpenGL ES to manage contexts & surfaces.
You might need to modify the include and library search paths by editing
QMAKE_INCDIR_EGL, QMAKE_LIBDIR_EGL and QMAKE_LIBS_EGL in
/home/elangovan/qt-everywhere-opensource-src-4.6.1/mkspecs/linux-g++-mx5x”

but in qmake.conf it has,

  1.     QMAKE_INCDIR_EGL      = /usr/local/DigiEL-5.6/x-tools/arm-cortex_a8-linux-gnueabi/arm-cortex_a8-linux-gnueabi/sys-root/usr/include/EGL
  2.     QMAKE_LIBDIR_EGL      = /usr/local/DigiEL-5.6/x-tools/arm-cortex_a8-linux-gnueabi/arm-cortex_a8-linux-gnueabi/sys-root/usr/lib
  3.      
  4.     QMAKE_LIBS_EGL       = -lEGL

when i use -v switching in config it gives errors as in the file – https://dl.dropboxusercontent.com/u/12382973/configError.txt [dl.dropboxusercontent.com]

Have you successfully compiled?

 Signature 

~Ravivarman~

November 14, 2013

almagest almagest
Lab Rat
36 posts

  1. usr/local/DigiEL-5.6/x-tools/arm-cortex_a8-linux-gnueabi/lib/gcc/arm-cortex_a8-linux-gnueabi/4.4.3/../../../../arm-cortex_a8-linux-gnueabi/bin/ld: cannot find -lxcb
  2. collect2: ld returned 1 exit status
  3. make: *** [egl4gles1] Error 1

Please use ‘code’-tags around your code, much more readable then.

From the errorlog you provided it looks like you are missing a libxcb.so library? Or variants of this.
Search your filesystem for this library, and also verify that its location is in the build path of the application.

Almagest.

November 14, 2013

dreamerindia dreamerindia
Lab Rat
128 posts

I’m using qt-everywhere-opensource-src-4.6.1 and there is no xcb library in that i think so.

 Signature 

~Ravivarman~

November 14, 2013

almagest almagest
Lab Rat
36 posts

Have you searched for ‘xcb’ among your files? Do that. Maybe this is included among the freescale-files, or possibly something that you could install in ubuntu as a package.

Please test these ideas first.

A.

November 14, 2013

dreamerindia dreamerindia
Lab Rat
128 posts

I can’t find xcb library in QMAKE_LIBDIR “/usr/local/DigiEL-5.6/x-tools/arm-cortex_a8-linux-gnueabi/arm-cortex_a8-linux-gnueabi/lib”.

Is xcb library is necessary for opengl compilation?

 Signature 

~Ravivarman~

November 14, 2013

almagest almagest
Lab Rat
36 posts

I honestly dont know whether you need it or not. You compiled some code and requested that the library should be linked in, but it failed since it could not find it.

Did you run this command to search?

  1. find / -name *xcb*

Another option could be to extract the precompiled image you got, and search among those files. The library might be there (and in correct arm-variant).

A.

November 14, 2013

dreamerindia dreamerindia
Lab Rat
128 posts

yes i did.

it showed xcb files only in x86. not in Qt folders.

 Signature 

~Ravivarman~

December 9, 2013

jst.guet jst.guet
Lab Rat
1 posts

dear almagest:
it is to late ,i am meet the same problem.and my ways: adding ‘-plugin-mouse-tslib’ option after ‘-qt-mouse-tslib’.

thans.

Page  
2

  ‹‹ [Solved] After compiling I have no /include/QtDesigner, Why?      Compile Errors Building Qt 4.6.3 With VS2008 For Windows x86_64 platforms ››

You must log in to post a reply. Not a member yet? Register here!