June 29, 2011

json json
Lab Rat
1 posts

Qt 5 build failure with QtWebKit

 

Hi,

I’m following the “building Qt 5” steps @ http://developer.qt.nokia.com/wiki/Building_Qt_5_from_Git but it’s choking in the QtWebKit submodule. My setup is Ubuntu 10.04.

It seems to build libQtWebKit OK but then it proceeds to build the tests (even though -nomake tests was used during configure). I then get the following warnings and it bails out:

/usr/bin/ld: warning: libQtXmlPatterns.so.4, needed by /usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtWebKit.so, may conflict with libQtXmlPatterns.so.5
/usr/bin/ld: warning: libQtGui.so.4, needed by /usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtWebKit.so, may conflict with libQtGui.so.5
/usr/bin/ld: warning: libQtNetwork.so.4, needed by /usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtWebKit.so, may conflict with libQtNetwork.so.5
/usr/bin/ld: warning: libQtCore.so.4, needed by /usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libQtWebKit.so, may conflict with libQtCore.so.5
.obj/release-shared/tst_qwebframe.o: In function `tst_QWebFrame::scrollToAnchor()’:
tst_qwebframe.cpp:(.text+0xdb13): undefined reference to `QWebFrame::scrollToAnchor(QString const&)’
tst_qwebframe.cpp:(.text+0xdbee): undefined reference to `QWebFrame::scrollToAnchor(QString const&)’
tst_qwebframe.cpp:(.text+0xdc1b): undefined reference to `QWebFrame::scrollToAnchor(QString const&)’
tst_qwebframe.cpp:(.text+0xdd6e): undefined reference to `QWebFrame::scrollToAnchor(QString const&)’
tst_qwebframe.cpp:(.text+0xdde1): undefined reference to `QWebFrame::scrollToAnchor(QString const&)’
.obj/release-shared/tst_qwebframe.o:tst_qwebframe.cpp:(.text+0xde0e): more undefined references to `QWebFrame::scrollToAnchor(QString const&)’ follow
collect2: ld returned 1 exit status

Has anyone else run into this issue and found a way to fix it?

I’ve gone through the build output and I don’t see any path references to my Qt4 desktop libs/headers…

Thanks!

0 replies

 
  ‹‹ Make Install puts Files in wrong path      Opengl Examples not installed with my QT SDK Kit for some reason its making me go beyond crazy! ››

You must log in to post a reply. Not a member yet? Register here!