May 7, 2011

4 characters 4 characters
Lab Rat
1 posts

Installation stops, crashes sh.exe and ssh-agent.exe

 

I’m trying to install qt sdk 1.1 on vista, at 81% in it stops and sh.exe and ssh-agent.exe crashes.

This is what the install log says.

  1. bash.exe: warning: could not find /tmp, please create!
  2.  
  3. /etc/profile: line 25: cd: C:/QtSDK/Maemo/home/asdf: No such file or directory
  4.  
  5. "runInstall(ExitCode: 5) went wrong
  6. 'C:\QtSDK/Maemo/4.6.2/bin/env.exe -i /bin/sh --login C:\QtSDK/Maemo/4.6.2/postinstall/postinstall.sh --nosleepontrap'"
  7.  
  8. "C:\QtSDK/Maemo/rebase/msysgit_rebase.exe -b 0x5200000 -o 0x10000 -v C:\QtSDK/Maemo/4.6.2/bin/msys-crypt-0.dll C:\QtSDK/Maemo/4.6.2/bin/msys-minires.dll C:\QtSDK/Maemo/4.6.2/bin/msys-gdbm-3.dll C:\QtSDK/Maemo/4.6.2/bin/msys-bz2-1.dll C:\QtSDK/Maemo/4.6.2/bin/msys-z.dll C:\QtSDK/Maemo/4.6.2/bin/msys-ssl-0.9.8.dll C:\QtSDK/Maemo/4.6.2/bin/msys-perl5_6.dll C:\QtSDK/Maemo/4.6.2/bin/msys-crypto-0.9.8.dll C:\QtSDK/Maemo/4.6.2/bin/msys-1.0.dll "
  9.  
  10. bash.exe: warning: could not find /tmp, please create!

Any ideas how to fix this?

3 replies

May 16, 2011

phaneswar phaneswar
Lab Rat
1 posts

I am getting similar kind of installation issue at around 72%. Progress bar shows “Installing component Madde Qt4.7.0” and I am getting a pop up xtar.exe failed and below is ‘OpenDetails’ content.

“runInstall(ExitCode: 9) went wrong
‘C:\QtSDK/Maemo/4.6.2/bin/env.exe -i /bin/sh —login C:\QtSDK/Maemo/4.6.2/postinstall/postinstall.sh —nosleepontrap’”

“C:\QtSDK/Maemo/rebase/msysgit_rebase.exe -b 0×5200000 -o 0×10000 -v C:\QtSDK/Maemo/4.6.2/bin/msys-crypt-0.dll C:\QtSDK/Maemo/4.6.2/bin/msys-minires.dll C:\QtSDK/Maemo/4.6.2/bin/msys-gdbm-3.dll C:\QtSDK/Maemo/4.6.2/bin/msys-bz2-1.dll C:\QtSDK/Maemo/4.6.2/bin/msys-z.dll C:\QtSDK/Maemo/4.6.2/bin/msys-ssl-0.9.8.dll C:\QtSDK/Maemo/4.6.2/bin/msys-perl5_6.dll C:\QtSDK/Maemo/4.6.2/bin/msys-crypto-0.9.8.dll C:\QtSDK/Maemo/4.6.2/bin/msys-1.0.dll “

May 16, 2011

ucomesdag ucomesdag
Lab Rat
226 posts

msysGit puts a sh.exe in the PATH that’s not compatible with MingW.
Removing the msysGit bin path from PATH in “Environment Variables” should resolve the problem.

I had that in System Properties / Advanced / Environment Variables nothing was set but when running PATH in a MS-Dos console it was.

The solution for me was adding a space at the end of the PATH variable in System Properties / Advanced / Environment Variables save it and then remove it and save it again.

 Signature 

Write “Qt”, not “QT” (QuickTime).

May 18, 2011

4 characters 4 characters
Lab Rat
1 posts

I couldn’t find msysGit in path, neither using console. I tried putting a space at the end and it still stops at 81% (Installing component Madde Qt 4.7.0) when sh.exe crashes. Ssh-agent.exe didn’t crash this time though, and the install log looks diffrent.

  1. C:\QtSDK\Maemo
  2. bash.exe: warning: could not find /tmp, please create!
  3.  
  4. Creating default target fremantle-pr13 ...
  5. This may take a while ...
  6.  
  7. Working on sysroot fremantle-arm-sysroot-20.2010.36-2-slim
  8. .....9....8....7....6....5....4....3....2....1....0
  9.  
  10. Creating missing links...
  11. done.
  12.  
  13. Working on toolchain arm-2007q3-51sb6-gdb71-arm-none-linux-gnueabi_w32
  14.  
  15. .....9....8....7....6....5....4....3....2....1....0
  16. Creating missing links...
  17. done.
  18.  
  19. Working on tools qt-tools-4.7.0-m0.20.32-w32
  20.  
  21. ..
  22. ...9...
  23. .8....7....6....5....4....3....2....1....0
  24. Creating missing links...
  25. done.
  26.  
  27. Find toolchain binaries
  28.  
  29. Link toolchain binaries

 
  ‹‹ [Moved] day one: failure...      [closed] sdk 1.1 bombs on perl ››

You must log in to post a reply. Not a member yet? Register here!