April 6, 2011

fosco fosco
Lab Rat
3 posts

[SOLVED]Error: “There is no device plugged in”

 

I’ve installed the Qt SDK v 1.1 with QT Creator v2.1, Symbian^1, Symbian^3 (Qt 4.6.3 and 4.7.2) and Desktop. Qt for Symbian 4.7.1 (Opensource).
In QT creator when I’ll run the application appear the following error “There is no device plugged in”.
In left bar of QT creator I select “Symbian Device” and show following options:

In all devices the option “Devices” is “Not connected”

5 replies

April 6, 2011

maxpayne maxpayne
Lab Rat
21 posts

Well..to build for Symbian you need to have a device connected..install Ovi Suite 2 and try connecting your mobile device, it will help you troubleshoot connectivity issues..otherwise build for Qt Simulator.

April 6, 2011

Zlatomir Zlatomir
Hobby Entomologist
366 posts

If this is acceptable you can remove the Deploy SIS Package step and just create a sis file that you can copy to device and install.
More information in this thread [developer.qt.nokia.com]

April 6, 2011

fosco fosco
Lab Rat
3 posts

In case, plug and transfer for a device only for test is not interesting for me and is not confortable to develop.
I was download the QT SDK v1.1 wich came with Nokia Simulator, but when I try to creat a new projetc show only this options:

  • Simulator Qt for MinGW 4.4 (Qt SDK)
  • Simulator Qt for Visual Studio 2005 (Qt SDK)
  • Simulator Qt for Visual Studio 2008 (Qt SDK)

Do exist a QT simulator for Symbian? Where I download it?

Thank you for the help.

April 6, 2011

Zlatomir Zlatomir
Hobby Entomologist
366 posts

Those are the simulators for Symbian.
In case you don’t use Visual Studio when install the SDK check only Simulator Qt for MinGW 4.4 and you can then target the simulator.

April 6, 2011

fosco fosco
Lab Rat
3 posts

Is it! =D
Thank you very much for the patience and for the help.

God bless you.

 
  ‹‹ Certification error in Remote Device Access?      Quick way to remove all contacts from a QContactManager? ››

You must log in to post a reply. Not a member yet? Register here!