February 1, 2011

RSousa RSousa
Lab Rat
20 posts

Problem: “This application has failed to start because the application…”

 

Hello,

I’m using Qt 4.7 with Visual Studio 2005.
I’ve built but when I run the executable, I received this messenge bellow.

“This application has failed to start because the application
configuration is incorrect. Review the manifest file for possible errors.
Reinstalling the application may fix this problem.”

Can you help me?

Thank you very much

all the best

Ricardo Sousa

6 replies

February 1, 2011

Gerolf Gerolf
Robot Herder
3235 posts

I think the redistributables of MSVS 2005 are not installed…

 Signature 

Nokia Certified Qt Specialist.
Programming Is Like Sex: One mistake and you have to support it for the rest of your life. (Michael Sinz)

February 1, 2011

Volker Volker
Ant Farmer
5428 posts

If you’re running this on your development machine, copy the needed Qt DLLs (QtCore, QtGui, probably more) into the directory where your exe lives.

February 2, 2011

RSousa RSousa
Lab Rat
20 posts

Thank you very much for your answers!:)

The redistributables of VS 2005 are installed…

and with Dependencies Walker program I realized that the DLL were missing but I copied to directory but it didn´t fixed … (Actually there is a missing dll which is msjava.dll that I can´t find anyhere in my PC)

There is another detail…

I´m using VS 2005 Express and I’ve used the libraries of VS 2008 of Qt libraries 4.7.1 for Windows.I’m not sure if this is correct since I´ve heard that can be used in the VS 2005.

Thank you very much

All the best

Ricardo Sousa

February 2, 2011

Gerolf Gerolf
Robot Herder
3235 posts

RSousa wrote:
There is another detail…

I´m using VS 2005 Express and I’ve used the libraries of VS 2008 of Qt libraries 4.7.1 for Windows.I’m not sure if this is correct since I´ve heard that can be used in the VS 2005.

That will not work. You have to use the libraries build with one MSVS compiler version.
All with MSVS2005 OR 2005 SP1 OR 2008 OR 2008 SP1 OR 2010 as all these compilers bring own msvcrt.dll versions, which implement the C runtime and therefore the heap.

If you use 2005, you must use Qt compiled with 2005!

 Signature 

Nokia Certified Qt Specialist.
Programming Is Like Sex: One mistake and you have to support it for the rest of your life. (Michael Sinz)

February 2, 2011

RSousa RSousa
Lab Rat
20 posts

Ok, that must be the reason then…

But how can I compile Qt 4.7 with VS2005?… I can´t find the source code of Qt 4.7.

I really thank you Gerolf.

All the best

Ricardo Sousa

February 2, 2011

Gerolf Gerolf
Robot Herder
3235 posts

If you download the source zip from here [qt.nokia.com] , you have it :-) Its the small link in the text.

Aditionally, if you downloaded a binary package, it also contains the complete source code.

 Signature 

Nokia Certified Qt Specialist.
Programming Is Like Sex: One mistake and you have to support it for the rest of your life. (Michael Sinz)

 
  ‹‹ Using signals of a parent class as notifiers for Q_PROPERTY      render QGraphicsEffect into pixmap? ››

You must log in to post a reply. Not a member yet? Register here!