September 10, 2013

phil69 phil69
Lab Rat
1 posts

No default repositories in Maintenance Tool

 

Hi,
when I start MaintenanceTool.exe (Windows 7, Qt 5.1.1, MinGW 4.8), all I can do with it is remove all components. For the package manager or updates, I need a repository. The “Default repositories” entry is empty, and I don’t know what to enter in temporary or user repositories. I’ve looked around a bit on your website and googled, but could not find anything.
Where can I find a list of Qt repository URLs?

5 replies

October 6, 2013

yalnte yalnte
Ant Farmer
48 posts

I have a similar problem – I haven’t been able to find the default paths yet and I’m reluctant to reinstall over a working system.

Does anyone know where the repos are please?

October 6, 2013

yalnte yalnte
Ant Farmer
48 posts

My workaround:

(i) Download Qt online installer Qt Project Downloads [qt-project.org]
(ii) Create a dummy installation directory (e.g. c:\temp\QtTemp)
(iii) try and install only those components you’re interested in to this directory (in my case just the Android components)
(iv) copy the new components across to the location it would have been in had the maintenance tool been working (e.g. C:\Qt\Qt5.1.1\)

Not ideal, but seems to have worked for my specific case.

November 29, 2013

AlterX AlterX
Hobby Entomologist
274 posts

Paths for repository are these, but I am not sure which ones are used for:

  1. http://download.qt-project.org/

 Signature 

Qt Ambassador
Real-time cooperative teams: http://www.softairrealfight.net

December 8, 2013

akelux akelux
Lab Rat
2 posts

I solved this issue by add the following url as a repository (in settings):
http://download.qt-project.org/online/qt5/windows/x86/online_repository/

Just leave the username and password empty :-)

March 12, 2014

jldominguez jldominguez
Lab Rat
4 posts

Great!
I also added android repository which you can guess but i’ll give it for not wasting time:

http://download.qt-project.org/online/qt5/windows/x86_android/online_repository/

 
  ‹‹ Qt Creator - Quick 2.0 Designer      [SOLVED] Memory leak detection in QT ››

You must log in to post a reply. Not a member yet? Register here!