January 9, 2011

stonegarden stonegarden
Lab Rat
1 posts

Webkit Qt4.7.1 VS 2008- Compilation with hundreds of same warnings

 

I try to compile Qt 4.7.1 with qt-everywhere-opensource-src-4.7.1.zip for the target WinCE on a normal XP-Windows machine.
During the compilation of Javascriptcore and Webkit the following warnings are shown whenever the PassRefPtr.h-Header is used:

C:\01_development\Qt\4.7.1-wince\src\3rdparty\webkit\JavaScriptCore\wtf/PassRefPtr.h(91) : warning C4396: “WTF::adoptRef”: Der Inlinespezifizierer kann nicht verwendet werden, wenn eine Friend-Deklaration auf die Spezialisierung einer Funktionsvorlage verweist.
…..

Is there anybody who was able to compile the webkit-part without these and some other warnings?
I found some information (http://www.mail-archive.com/chromium-dev@googlegroups.com/msg00107.html)
about this warnings, but, although this infos are from Sept 2008 the actual version of the webkit-sources/headers is delivered without the mentioned changes.

The dev-env is like that:

XP Professional, Visual Studio 2008 Professional and for target Windows Mobile 5.0 SDK R2

Thanks in advance , Michael

1 reply

January 14, 2011

Mohsen Mohsen
Lab Rat
748 posts

i have the same problem with webkit. it seems it’s not supported for WinCE by Qt so far.

 Signature 

www.madagon.com

 
  ‹‹ cIRCle project is now discontinued and it’s repository is opened.      setting ampersand(&) as a Text for a push button ››

You must log in to post a reply. Not a member yet? Register here!