April 18, 2013

chrisco chrisco
Lab Rat
14 posts

Qt Creator 2.7, empty Locals and Expressions view?



We are running Qt5 on our ARM device. On the ARM device we start gdbserver with the application we want to debug remotely.
On our development PC, we use the correct gdb version to connect to the gdbserver. Then we start the debugging and things like setting breakpoints and stepping all work fine, no problems there!

To show the stack when reaching a breakpoint we have to doubleclick on the ‘thread’ in the thread view manually, which seems a bit strange.
But our biggest problem is that no ‘locals and expressions’ are shown.. When using the gdb command ‘info locals’ in the ‘debugger log’ view we can clearly see that gdb knows about the locals. So it seems Qt creator is failing to display them.

Does anybody have an idea what is going wrong?


4 replies

April 27, 2013

andrep andrep
Ant Farmer
41 posts

Please attach the debugger log (contents of right pane of Windows->View->Debugger Log). And please note that there aren’t many Qt Creator developers attending this forum here, whereas the mailing list and the #qt-creator IRC channel on FreeNode are typically watched.

May 30, 2013

gavofyork gavofyork
Lab Rat
1 posts

Was there ever a solution for this? I have the same issue.

Debug log is at http://pastebin.com/qW1bQLkt

It seems to be stuck with the ‘bb’ command not being found. What is ‘bb’?



June 1, 2013

andrep andrep
Ant Farmer
41 posts

The poblem is “IOError: [Errno 13] Permission denied: ‘/usr/local/share/qtcreator/dumper/gbridge.py’”. Does this file exist, and is it readable?

September 7, 2013

controlhorus controlhorus
Lab Rat
18 posts


Same problem here. Did anybody find a solution for that problem?

andrep wrote:
… whereas the mailing list and the #qt-creator IRC channel on FreeNode are typically watched.

Where are the mailing list? (Edit: as usual , post and found, http://lists.qt-project.org/ )

Thanks and best regards

  ‹‹ Qt Creator editor font size      Setting Qt Creator to default layout causes lock up... ››

You must log in to post a reply. Not a member yet? Register here!