January 17, 2013

cokefish cokefish
Lab Rat
28 posts

I cannot load sqlite table when my qml application autostart on linux

 

I use sqlite db in my qml application.
I want my application could be autostart when my linux device start up.

when I debug my application, I run my qml application on command line after my linux device startup,
the application could run well.

but after I append it into the system /etc/initab, every time the qml application runs while the linux device start up,
it will prompt error as below

Error: no such table: XXXX Ubable to execute statement

Could you please tell me the reason why?

1 reply

January 17, 2013

daliusd daliusd
Lab Rat
132 posts

Maybe you run it under different user from /etc/initab (e.g. as root) and naturally it looks for DB in other location.

 
  ‹‹ [SOLVED] (Qt 5) Qt Quick 2 application - will not link when c++ class instance created - cpp is not being built into an .obj      QDeclarativeItem based on QML (Load QML file from QDeclarativeItem) ››

You must log in to post a reply. Not a member yet? Register here!