October 12, 2012

pjmlp pjmlp
Lab Rat
3 posts

How to get mingw 4.4

 

Hi everyone,

I made the stupid mistake of uninstalling the Qt SDK version 1.2.1 ,in the hope of being able to use a more recent version of Qt Creator by installing everything separately.

Now I’ve discovered that it is an epic job trying to download an workable version of mingw 4.4 (from 2009!) version from MinGW website.

Am I now forced to undo everything to install the old SDK? Does Qt compile without issues with more recent versions of mingw, which ones?

Thanks in advance,
Paulo

8 replies

October 12, 2012

MuldeR MuldeR
Hobby Entomologist
628 posts

Why would you want to use an old/outdated MinGW, instead of just grabbing the current one?

Anyway, if need an older version, such as v4.4, you may have a look here:
http://tinyurl.com/oldgmingw

 Signature 

My OpenSource software at: http://muldersoft.com/ | Qt 4.8.5 Win32 Static: http://tinyurl.com/qt48static

Go visit the coop: http://youtu.be/Jay-fG9eaYk

October 12, 2012

pjmlp pjmlp
Lab Rat
3 posts

Because in the download page says Qt 4.8.3 requires mingw 4.4, and I don’t feel like compiling everything from source.

Thanks for the link, I’ll try it out.

October 13, 2012

pwnstar23 pwnstar23
Lab Rat
69 posts

I’m using a newer version of mingw 4.6.2 I think to compile projects with qtcreator 2.5.2(stand alone version and/or sdk qt creator 2.4.1 ). It will use the precompiled QT library from the sdk, so you can use the newer mingw to compile your code.

Also you probably have to use the newer debugger that comes with mingw 4.6.2

They are also going to release QT5 soon. I would expect they update the sdk then as well with the even newer QT Creator. The QT Creator on the git repo is 2.6.x .

I also tried and failed to get it compiled on windows. But linux was as easy as download and execute 3 commands.

October 13, 2012

JKSH JKSH
Area 51 Engineer
2254 posts

The MinGW Qt libraries were precompiled with GCC 4.4, so you need a version of MinGW whose compiler is binary-compatible with GCC 4.4. I’m not sure about GCC 4.5 and 4.6, but I know for sure that GCC 4.7 (from the latest MinGW) is incompatible.

Here’s how I got MinGW 4.4:

  1. Install Qt SDK 1.2.1
  2. Make a copy of C:\QtSDK\mingw\ (for compiling) and C:\QtSDK\pythongdb (for debugging)
  3. Uninstall Qt SDK 1.2.1
  4. Tell my latest Qt Creator (2.5.2) where to find my latest Qt libs (4.8.3) and my old MinGW (from #2)

You can try some of the more recent ones and see if they work, but the version from the SDK is guaranteed to work.

October 13, 2012

codenode codenode
Lab Rat
70 posts

Could be that I got this still installed on one of my machines. Could send you the bin folder maybe.

Also Google gave me this link, where you maybe can download the mingw 4.4 sources:
http://de.sourceforge.jp/projects/sfnet_mingw/downloads/MinGW/Base/gcc/Version4/Previous Release gcc-4.4.0/gcc-4.4.0-mingw32-src-2.tar.gz/

Also, CodeBlocks offers a Version with MinGW from 2010, that might be 4.4 if you’re lucky:
http://www.codeblocks.org/downloads/26

October 13, 2012

pjmlp pjmlp
Lab Rat
3 posts

Thanks everyone for the helpful comments.

In the end I took the solution proposed by JKSH.

Meanwhile I just found out about QTBUG-27258, but that is a minor annoyance in respect to be able to use the latest versions.

Thanks once again.

November 12, 2012

grizzomble grizzomble
Lab Rat
1 posts

I would get it right from Nokia.
ftp://ftp.qt.nokia.com/misc/MinGW-gcc440_1.zip [ftp.qt.nokia.com]

December 31, 2012

ShaoLin ShaoLin
Lab Rat
1 posts

Hi guys, I searched a lot for mingw 4.4 on the web, and since nokia ftp isn’t available anymore, I created a blog post to share it freely:

http://nosymbolfound.blogspot.com/2012/12/since-until-now-qt-under-windows-is.html

Bye!

 
  ‹‹ QtCreator UI-designer suddenly fails to add/find slots      [solved]Using QFileDialog::getOpenFileName and QFileDialog::getSaveFileName, how to get cross platform root directory? ››

You must log in to post a reply. Not a member yet? Register here!