July 8, 2010

equalsraf equalsraf
Lab Rat
11 posts

Can’t install qt-mobility 1.0.1

 

When attempting to build qt-mobility 1.0.1 against opensuse 11.2 with Qt 4.7, make fails and seems to be targeting some awkward locations for installation and ignoring the prefix, make fails trying to copy something, which is odd since I’m not running make install yet

(..suppressed boring parts…)

  1. cd declarative/ && make -f Makefile
  2. make[2]: Entering directory `/home/raf/Download/qt-mobility-opensource-src-1.0.1/plugins/declarative'
  3. cd serviceframework/ && make -f Makefile
  4. make[3]: Entering directory `/home/raf/Download/qt-mobility-opensource-src-1.0.1/plugins/declarative/serviceframework'
  5. Makefile:272: warning: overriding commands for target `install_target'
  6. Makefile:263: warning: ignoring old commands for target `install_target'
  7. Makefile:276: warning: overriding commands for target `uninstall_target'
  8. Makefile:267: warning: ignoring old commands for target `uninstall_target'
  9. cp -f qmldir /usr/imports/QtMobility/serviceframework/qmldir
  10. cp: cannot create regular file `/usr/imports/QtMobility/serviceframework/qmldir': No such file or directory
  11. make[3]: *** [/usr/imports/QtMobility/serviceframework/qmldir] Error 1
  12. make[3]: Leaving directory `/home/raf/Download/qt-mobility-opensource-src-1.0.1/plugins/declarative/serviceframework'
  13. make[2]: *** [sub-serviceframework-make_default] Error 2
  14. make[2]: Leaving directory `/home/raf/Download/qt-mobility-opensource-src-1.0.1/plugins/declarative'
  15. make[1]: *** [sub-declarative-make_default] Error 2
  16. make[1]: Leaving directory `/home/raf/Download/qt-mobility-opensource-src-1.0.1/plugins'
  17. make: *** [sub-plugins-make_default-ordered] Error 2

Has anyone seen this before? It seems that the whatever is in plugins/declarative is ignoring the prefix and trying to copy files into ./usr/imports/QtMobility/

1 reply

July 15, 2010

Tobias Hunger Tobias Hunger
Robot Herder
3387 posts

The qmldir files need to get copied into (a subdirectory of) the directory you are building in. Looks like that fails for you. Please open a bugreport against QTMOBILITY in our bugtracker [bugreports.qt.nokia.com].

 
  ‹‹ Problem compiling QT4 4.7.0      Static linked pre-compiled Qt binaries? ››

You must log in to post a reply. Not a member yet? Register here!