April 28, 2012

cloudbuster cloudbuster
Lab Rat
39 posts

[SOLVED]failed to install Qt SDK…cannot execute binary file

 

  1. drwxr-xr-x.  3 qt4user qt4user      4096 Apr 27 22:56 ./
  2. drwx------. 59 qt4user qt4user      4096 Apr 27 19:37 ../
  3. -rw-rw-r--.  1 qt4user qt4user      4368 Jan  5 12:10 adobe-release-i386-1.0-1.noarch(1).rpm
  4. -rw-rw-r--.  1 qt4user qt4user      4368 Jan  5 12:07 adobe-release-i386-1.0-1.noarch.rpm
  5. -rw-rw-r--.  1 qt4user qt4user     64370 Apr 19 14:53 Corsair20-233-225Apr19Apr2512cd12.pdf
  6. -rw-rw-r--.  1 qt4user qt4user   2787328 Apr  5 10:45 dft32_v416_b00.iso
  7. -rw-------.  1 qt4user qt4user        50 Apr 27 11:50 .directory
  8. -rw-rw-r--.  1 qt4user qt4user 113222035 Apr 27 22:03 eclipse-cpp-indigo-SR2-incubation-linux-gtk-x86_64.tar.gz
  9. -rw-rw-r--.  1 qt4user qt4user 151016487 Apr 27 21:16 eclipse-linuxtools-indigo-SR2-incubation-linux-gtk-x86_64.tar.gz
  10. -rw-rw-r--.  1 qt4user qt4user   6733489 Jan  4 21:13 flash-plugin-11.1.102.55-release.i386.rpm
  11. -rw-rw-r--.  1 qt4user qt4user     25244 Apr 19 10:41 g-cvr-120419-discovery-8a.grid-6x2.jpg
  12. drwxr-----. 19 qt4user qt4user      4096 Jan  7 19:50 hplip-3.11.12/
  13. -rw-rw-r--.  1 qt4user qt4user  21539132 Jan  5 14:06 hplip-3.11.12.run
  14. -rw-rw-r--.  1 qt4user qt4user  21539132 Jan  7 19:27 hplip-3.11.12x.run
  15. -rw-rw-r--.  1 qt4user qt4user  24344882 Apr 27 11:35 qt-eclipse-integration-linux.x86_64-1.6.1.tar.gz
  16. -rwxrw-r--.  1 qt4user qt4user 804478453 Apr 26 23:49 QtSdk-offline-linux-x86_64-v1.2.1.run*
  17. -rwxrw-r--.  1 qt4user qt4user  27202203 Apr 27 22:56 QtSdk-online-linux-x86_64-v1.2.1.run*
  18. [root@lmkiii Downloads]# ./QtSdk-offline-linux-x86_64-v1.2.1.run
  19. -bash: ./QtSdk-offline-linux-x86_64-v1.2.1.run: cannot execute binary file
  20. [root@lmkiii Downloads]# ./QtSdk-online-linux-x86_64-v1.2.1.run
  21. -bash: ./QtSdk-online-linux-x86_64-v1.2.1.run: cannot execute binary file
  22. [root@lmkiii Downloads]#

yes I did chmod u+x on the .bin files

4 replies

April 28, 2012

bobby bobby
Lab Rat
44 posts

This may be better placed in the installation forum.

Based on the other packages you listed, you may want to download the 32 bit version of the installer and try that.

 Signature 

“Linux is not user-friendly.” It _is_ user-friendly. It is not ignorant-friendly and idiot-friendly.
—-Source unknown

April 28, 2012

Luca Luca
Ant Farmer
637 posts

The SDK shouldn’t be installed as root.

Try to install it as “qt4user” or if you want to install as “root” user you must do this before:

  1. chmod o+x ./QtSdk-online-linux-x86_64-v1.2.1.run

April 30, 2012

cloudbuster cloudbuster
Lab Rat
39 posts

32 bit version installed successfully…64 did not

failed for several reasons

the only projects I have are eclipse workstation projects

how do I start the QT SDK

Did not show up under the Fedora 16 (64 bit) menu for development

Using the page left over from the install I selected a working .pro file in a non eclipse project

I got partial window display…how does one enter arguments

Normally to run this .pro project I enter: ./QtFigs4 figs.xml

Guess I cannot use yum or yumex to uodate

wait…seems to be an updater facility

May 7, 2012

bobby bobby
Lab Rat
44 posts

Inside of the QtSDK is QtCreator/bin/qtcreator

Run that and rock out

 Signature 

“Linux is not user-friendly.” It _is_ user-friendly. It is not ignorant-friendly and idiot-friendly.
—-Source unknown

 
  ‹‹ Qt4.8 anomalie on UBUNTU12.4 versus Fedora16 Fedora16 version of Qt application works fully      New context help in QtCreator has awful design! ››

You must log in to post a reply. Not a member yet? Register here!