April 27, 2012

lsatenstein lsatenstein
Lab Rat
15 posts

Qt4.8 anomalie on UBUNTU12.4 versus Fedora16   Fedora16 version of Qt application works fully


I have the identical application on UBUNTU 12.4. I do the qmake -project followed by qmake and then make

Both environments compile to form an executable, and with zero warnings.
The application, when in production is fully keyboard driven. (No mouse intended)
When the application is started on UBUNTU, absolutely zero (no) keyboard characters are detected. In particular, the cursor movement keys, etc.

When on Fedora, the keyboard is fully recognized, the cursor keys move the focus as anticipated.

What is blocking the UBUNTU version of Qt4.8 SDK (both versions downloaded and installed on 2012-04-24)

One observed fact. If the Ubuntu receives a single mouseclick. anywhere on the active Qt Window, following the mouse click, the UBUNTU code works identically to the Fedora version.

This same problem was occuring with earlier versions of UBUNTU.

Has anyone experienced this phenomenon&

Do I need to generate a dummy mouseclick to get Ubuntu version of Qt application initialized?

1 reply

April 27, 2012

Tobias Hunger Tobias Hunger
Ant Farmer
3387 posts

Have you tried to report a bug to ubuntu?

  ‹‹ [SOLVED] SDK install ubuntu 12.04 unity 2D not working.      [SOLVED]failed to install Qt SDK...cannot execute binary file ››

You must log in to post a reply. Not a member yet? Register here!