March 7, 2012

hsn22 hsn22
Lab Rat
1 posts

setting up qt mobility with qt 4.7


hello all,

i am targetting symbian devices from symbian^1 onwards. i will be making extensive use of the qt mobilitiy api (pref v 1.2 +) while researching for support, i came across this page: link 1 [] as per which (or misconstrued by me), mobility 1.2.1 will run with qt 4.7.3 on symbian^1.

however, the page at link 2 [] only says that qt 4.6 + is required. if that is the case, then as per the first link, qt mobility should be supported all the way back till s60 3rd ed fp 1.

can anyone tell me which one is correct?

to test it out, i downloaded the nokia sdk 1.2. which, after install, i realised is for qt 4.8. thus, i downloaded sdk 1.1.2. this installed qt mobility 1.1.2 (i think) and qt 4.6.3 and qt 4.7.3.

i tried help>start updater to try and get mobility 1.2 for qt 4.6.3 and instead, the updater only shows the following:

mobility 1.0.4 for qt 4.6.3
mobility 1.1.3 for qt 4.7.3
mobility 1.2.1 for qt 4.7.4
(and some variants)

there is one more entry “QT mobility APIs” which shows the installed version as 1.1.3 and new version as 1.2.0 – but does not specify which version of qt this is for and there is no information.


how can i enable qt mobility 1.2 for qt 4.7.3 (qt 4.6.3 would be nice too) in qt creator?

thanks for the help :)


after some searching, i found the qt mobility 1.2 beta release package here []

i’m downloading the symbian specific package. will run it and update with details. hopefully this will help somebody else stumbling through this maze.

some more searching yields this page [] as per which,

“Mobility 1.2 requires Qt 4.7.0 as a minimum.”

is there no authoritative source that i can refer to?

[i’m cross posting from the nokia forums as i haven’t been able to get a reply yet]

0 replies

  ‹‹ Mixing EGL and GUI.. different overlays in OMAP processor.      QPainter for paint an image at the double resolution ››

You must log in to post a reply. Not a member yet? Register here!