qt installation (with vs10)

Page  
2

October 22, 2010

Volker Volker
Ant Farmer
5331 posts

Normally, configure.exe (with some switches, if needed) works just fine. Did you call it via

  1. .\configure.exe

or
  1. .\configure

There is a configure (without .exe) which happens to be a unix shell script, and that does not work on windows, of course :-)

Calling nmake without running configure.exe before will not work, as there are no makefiles to use.

October 22, 2010

jigfjifd jigfjifd
Lab Rat
19 posts

Hello again,
I’ve tried everything I could think of, including
configure
configure.exe
.\configure
.\configure.exe
configuration.exe
configuration
after or before the ‘cd’, none of it works.
So do I need to add something else to ‘path’ ?
Do I have to do something related to this note : “Note: If you don’t use the configured shells, which is available in the application menu, in the Open Source Versions of Qt, configure requires that sh.exe is not in the path or that it is run from msys. This also goes for mingw32-make.” ?

Thanks

October 22, 2010

Volker Volker
Ant Farmer
5331 posts

If you call

  1. configure.exe -help
there should at least be some output on the shell, regardless of any paths etc.

October 22, 2010

jigfjifd jigfjifd
Lab Rat
19 posts

No, there’s nothing.
it says ‘configure.exe’ is not recognized as an internal or external command, an executable program or a file of commands.
I have to type this in the visual studio command prompt, right?
(if I type this in cmd.exe, it gives the same result).

October 22, 2010

Volker Volker
Ant Farmer
5331 posts

You must cd into the directory where configure.exe lives or call it via its complete path.

October 22, 2010

jigfjifd jigfjifd
Lab Rat
19 posts

okay, I’ve made a search in my computer and it is in
C:\Qt\4.7.0\qt-everywhere-opensource-src-4.7.0
not in
C:\Qt\4.7.0\
sorry. I thought it was a Microsoft windows command or something, so I didn’t try to find the executable before.

So what do I need to do now exactly?
You haven’t answered me regarding the path variables and the note, both of which are mentionned in the website you gave me.

October 22, 2010

Volker Volker
Ant Farmer
5331 posts

I don’t know for the note. If you don’t have MinGW or a bash or such installed, you probably don’t need to take care of it.

I never set a PATH variable when I compiled on Windows. Just start the Visual Studio Command prompt and enter:

  1. cd C:\Qt\4.7.0\qt-everywhere-opensource-src-4.7.0
  2. .\configure.exe
  3. nmake

And then have a cup of coffee or better go for lunch or dinner – it takes a looooong time until everything is compiled :-)

October 22, 2010

jigfjifd jigfjifd
Lab Rat
19 posts

Hello,
so I typed it and here is the result :

  1. C:\Qt\4.7.0\qt-everywhere-opensource-src-4.7.0\>configure.exe
  2. Unable to detect the platform from environment. Use -platform command lineargument or set the QMAKES
  3. PEC environment variable and run configure again
  4. See the README file for a list of supported operating systems and compilers.
  5. Usage: (<<followed by hundreds of lines explaining its complicated usage>>)
  6.  
  7.  
  8. C:\Qt\4.7.0\qt-everywhere-opensource-src-4.7.0\>

The default options seem to have failed (“Unable to detect the platform”) and the usage of this executable seems quite complicated, so maybe you can help me once more :)

October 22, 2010

Volker Volker
Ant Farmer
5331 posts

  1. .\configure.exe -platform win32-msvc2010

October 22, 2010

jigfjifd jigfjifd
Lab Rat
19 posts

thanks, it’s working so far.

October 22, 2010

Volker Volker
Ant Farmer
5331 posts

Seems like you started cmd.exe, you must start the Visual Studio Command Prompt (in VS2005/2008 it’s somewhere in the Start Menu / All Programs / MS Visual Studio 200x / as far a I remember); you’ll have to look around…

October 22, 2010

jigfjifd jigfjifd
Lab Rat
19 posts

yes you’re absolutely right, I noticed a few seconds later and edited my post. Sorry for the stupid question

October 23, 2010

jigfjifd jigfjifd
Lab Rat
19 posts

so…
the compilation is done (finally!).
What do I have to do now to link the framework to the vs add in, and are there any files that I don’t need anymore ?

October 23, 2010

Volker Volker
Ant Farmer
5331 posts

The VS addin does work independently from your Qt version. Just run the installer. You then must make your self compiled Qt visible to the plugin, there is an entry in the new Qt menu of Visual Studio – just look around. Some more info on the addin can be found here [doc.qt.nokia.com]

Just play around :-)

October 24, 2010

jigfjifd jigfjifd
Lab Rat
19 posts

Hello again,

Can you give me a more detailed answer please ? I’ve been trying to look and play around but with no result. – I don’t really understand why you ask me to run the ‘installer’.
I thought that “That’s all. Qt is now installed.”, once I have done nmake. – I don’t really understand either how to build a qt application from vs, it still seems not to be working. – Finally, I didn’t get which files or directories are part of the installation/compilation process and can be deleted.

Thanks.

Page  
2

  ‹‹ need help in installing qt mobility      Does Qt 4.6 or 4.7 support postgresSQL 9.0 ? please help ››

You must log in to post a reply. Not a member yet? Register here!