January 11, 2012

Sapienti132 Sapienti132
Lab Rat
9 posts

Fehler in beim ausführen von nmake

Page  
1

Hallo schönen guten Tag.
Kommen wir sofort auf denn Punkt ich bekomme in der Console eine Error Meldung
wenn ich nmake ausführe

Betriebsystem: Win7 ×64
Qt: v4.8.0
Configuration: “configure -platform win32-msvc2010”

  1. Microsoft (R) Program Maintenance Utility, Version 10.00.30319.01
  2. Copyright (C) Microsoft Corporation. Alle Rechte vorbehalten.
  3.  
  4.         link /LIBPATH:"d:\Qt\4.8.0\lib" /LIBPATH:"d:\Qt\4.8.0\lib" /NOLOGO /DYNA
  5. MICBASE /NXCOMPAT /INCREMENTAL:NO /DLL /MANIFEST /MANIFESTFILE:"tmp\obj\release_
  6. shared\qgenericbearer.intermediate.manifest" /VERSION:4.80 /OUT:..\..\..\..\plug
  7. ins\bearer\qgenericbearer4.dll @C:\Users\Jason\AppData\Local\Temp\nm96A.tmp
  8. LINK : fatal error LNK1104: Datei "..\..\..\..\plugins\bearer\qgenericbearer4.dl
  9. l" kann nicht geöffnet werden.
  10. NMAKE : fatal error U1077: ""C:\Program Files (x86)\Microsoft Visual Studio 10.0
  11. \VC\BIN\link.EXE"": Rückgabe-Code "0x450"
  12. Stop.
  13. NMAKE : fatal error U1077: ""C:\Program Files (x86)\Microsoft Visual Studio 10.0
  14. \VC\BIN\nmake.exe"": Rückgabe-Code "0x2"
  15. Stop.
  16. NMAKE : fatal error U1077: "cd": Rückgabe-Code "0x2"
  17. Stop.
  18. NMAKE : fatal error U1077: "cd": Rückgabe-Code "0x2"
  19. Stop.
  20. NMAKE : fatal error U1077: "cd": Rückgabe-Code "0x2"
  21. Stop.
  22.  
  23. D:\Qt\4.8.0>

18 replies

January 11, 2012

koahnig koahnig
Dinosaur Breeder
2933 posts

Willkommen bei devnet

Ich gehe davon aus, dass die Fehlermeldung direkt beim Compilieren nach dem Configure auftritt.

Bei den msvc Plattformen liegt dies in der Regel daran, dass der Commandprompt von Windows aus geöffnet wird. Es muss der Command-Prompt von msvc verwendet werden. Bei msvc 2005 ist dieser unter “Tools” als “Visual Studio 2005 Command Prompt” zu finden. Dort werden ein paar Settings für VS ergänzt.

Dies ist auf alle Fälle eine Sache zum Abklären, auch wenn ich meine dass die Fehlermeldung anders sein sollte. :-(

January 11, 2012

koahnig koahnig
Dinosaur Breeder
2933 posts

Oh, habe vergessen, dass der neuste Service Pack installiert sein sollte.

January 11, 2012

Sapienti132 Sapienti132
Lab Rat
9 posts

Ich benutze ja denn -> Visual Studio-Eingabeaufforderung (2010) sonst würde ja nmake nicht ausgeführt werden. es leuft ja die ganze Zeit durch bisauf in diesem Abschnitt. Habe mal mehr Makiert das man das sieht.

  1. Microsoft (R) Program Maintenance Utility, Version 10.00.30319.01
  2. Copyright (C) Microsoft Corporation. Alle Rechte vorbehalten.
  3.  
  4.         "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\BIN\nmake.exe" -
  5. f Makefile.Debug all
  6.  
  7. Microsoft (R) Program Maintenance Utility, Version 10.00.30319.01
  8. Copyright (C) Microsoft Corporation. Alle Rechte vorbehalten.
  9.  
  10.         "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\BIN\nmake.exe" -
  11. f Makefile.Release all
  12.  
  13. Microsoft (R) Program Maintenance Utility, Version 10.00.30319.01
  14. Copyright (C) Microsoft Corporation. Alle Rechte vorbehalten.
  15.  
  16.         link /LIBPATH:"d:\Qt\4.8.0\lib" /LIBPATH:"d:\Qt\4.8.0\lib" /NOLOGO /DYNA
  17. MICBASE /NXCOMPAT /INCREMENTAL:NO /DLL /MANIFEST /MANIFESTFILE:"tmp\obj\release_
  18. shared\qgenericbearer.intermediate.manifest" /VERSION:4.80 /OUT:..\..\..\..\plug
  19. ins\bearer\qgenericbearer4.dll @C:\Users\Jason\AppData\Local\Temp\nm96A.tmp
  20. LINK : fatal error LNK1104: Datei "..\..\..\..\plugins\bearer\qgenericbearer4.dl
  21. l" kann nicht geöffnet werden.
  22. NMAKE : fatal error U1077: ""C:\Program Files (x86)\Microsoft Visual Studio 10.0
  23. \VC\BIN\link.EXE"": Rückgabe-Code "0x450"
  24. Stop.
  25. NMAKE : fatal error U1077: ""C:\Program Files (x86)\Microsoft Visual Studio 10.0
  26. \VC\BIN\nmake.exe"": Rückgabe-Code "0x2"
  27. Stop.
  28. NMAKE : fatal error U1077: "cd": Rückgabe-Code "0x2"
  29. Stop.
  30. NMAKE : fatal error U1077: "cd": Rückgabe-Code "0x2"
  31. Stop.
  32. NMAKE : fatal error U1077: "cd": Rückgabe-Code "0x2"
  33. Stop.
  34.  
  35. D:\Qt\4.8.0>

January 11, 2012

koahnig koahnig
Dinosaur Breeder
2933 posts

Sorry. Der Prompt-start ist ein Standardfehler bei der Übersetzung mit VisualStudio. Es hatte mich schon etwas gewundert, da die Meldung doch anders aussehen sollte.

Kann es ein Rechteproblem sein? Admin-Rechte oder ähnliches?

Ansonsten muss ich passen.

January 11, 2012

Sapienti132 Sapienti132
Lab Rat
9 posts

Kann ja die Visual CMD mal mit Administrator starten.
obs funktioniert hat oder sonstiges gebe ich bescheid ;)

January 13, 2012

Sapienti132 Sapienti132
Lab Rat
9 posts

Wieder ein error

configure -platform win32-msvc2010 -qt-sql-mysql -plugin-sql-mysql -L D:\MySQL\lib -I D:\MySQL\include

dann ganz normal nmake und dann nach ne weile kam das PasteBin [pastebin.com]

January 13, 2012

koahnig koahnig
Dinosaur Breeder
2933 posts

Diesmal ist aber der Fehler anscheinend bei mySql. War das das letzte Mal auch schon dabei?

Mir fiel gerade noch ein, dass ich auch schon Fehlermeldungen beim Compilieren hatte, aber das nmake einfach nochmals starten konnte. Dann lief es weiter. Hinterlässt allerdings einen faden Nachgeschmack :-(

January 13, 2012

Sapienti132 Sapienti132
Lab Rat
9 posts

Naja hmm ja ist jetzt ein ganz anderer PC gewesen wo alles Leer war aber details sind gleich also ist win7 64bit etc.

January 13, 2012

koahnig koahnig
Dinosaur Breeder
2933 posts

Schon einmal das wiederholte Starten von nmake probiert?

Da nun mySql hinkommt, kann es noch andere Fehler geben. Z.B. Pfade, etc falsch

January 13, 2012

Sapienti132 Sapienti132
Lab Rat
9 posts

Ich brauche ja alles o wie es ist also alles muss funktionieren du meinst ja das bei dir es net so pralle war ?

January 13, 2012

koahnig koahnig
Dinosaur Breeder
2933 posts

Na ja, eher nur der Nachgeschmack. Gelaufen ist trotzdem alles. Deshalb wäre es mal einen Versuch wert.

January 13, 2012

Sapienti132 Sapienti132
Lab Rat
9 posts

Ich schaue mal. melde mich dann.

//edit Klapt nicht selber error :S

January 13, 2012

koahnig koahnig
Dinosaur Breeder
2933 posts

Ich würde erst einmal mySql weglassen. Wenn man das andere Problem gelöst hat, kann man weitergehen.

Es gibt anscheinend mehr Probleme mit msvc 2010. Auf alle Fälle muss man alle Fixes eingespielt haben. Vielleicht solltest Du das Ganze einmal in das Englische Forum geben. Deutsch wird sehr selten benutzt.

January 13, 2012

Sapienti132 Sapienti132
Lab Rat
9 posts

Das liegt ja nur am mysql seit dem ich das drinne habe gehts ncith aberi ch BRAUCHE es.

January 14, 2012

koahnig koahnig
Dinosaur Breeder
2933 posts
Sapienti132 wrote:
Das liegt ja nur am mysql seit dem ich das drinne habe gehts ncith aberi ch BRAUCHE es.

Ok, d.h. der ursprüngliche Fehler vom 11. Jan ist gelöst?
Es liegt nur noch ein Problem mit mySql vor?

Page  
1

  ‹‹ pyside-uic für openSUSE, Versionswirrwar und Borderlayout      VS2010 und QT 4.8.0 scheitert ››

You must log in to post a reply. Not a member yet? Register here!