July 3, 2011

brucewuu brucewuu
Lab Rat
34 posts

macdeployqt erros on mac

 

I created a simple application , see

  1. #include <QtGui/QtGui>
  2. int main(int argc,char **argv)
  3. {
  4. QApplication app(argc,argv);
  5. QWidget win;
  6. win.show();
  7. return app.exec();
  8. }

and build it like this

  1. qmake -project
  2. qmake -spec macx-g++
  3. make

and get the test1.app , it can run , while I depoly it with macdeployqt test1.app/ verbose=1 -dmg , the errors happened , see

  1. ERROR:  to "test1.app/Contents/PlugIns/imageformats/libqico.dylib"
  2. ERROR: file copy failed from "/Developer/Applications/Qt/plugins/imageformats/libqjpeg.dylib"
  3. ERROR:  to "test1.app/Contents/PlugIns/imageformats/libqjpeg.dylib"
  4. ERROR: file copy failed from "/Developer/Applications/Qt/plugins/imageformats/libqmng.dylib"
  5. ERROR:  to "test1.app/Contents/PlugIns/imageformats/libqmng.dylib"
  6. ERROR: file copy failed from "/Developer/Applications/Qt/plugins/imageformats/libqtiff.dylib"
  7. ERROR:  to "test1.app/Contents/PlugIns/imageformats/libqtiff.dylib"
  8. ERROR: file copy failed from "/Developer/Applications/Qt/plugins/qmltooling/libtcpserver.dylib"
  9. ERROR:  to "test1.app/Contents/PlugIns/qmltooling/libtcpserver.dylib"
  10. WARNING:
  11. WARNING: "test1.app/Contents/Resources/qt.conf" already exists, will not overwrite.
  12. WARNING: To make sure the plugins are loaded from the correct location,
  13. WARNING: please make sure qt.conf contains the following lines:
  14. WARNING: [Paths]
  15. WARNING:   Plugins = PlugIns

is there any problems with the using of qmake and macdeployqt I used , anyone could help me and tell me how to deploy applications on mac ? thanks very much

[EDIT: code formatting, Volker]

 Signature 

wish all the best to you from
bruce wuu
Autodesk China Inc.
SW Developer
M&E Product Developerment Group
Work 137 6411 8921
.(JavaScript must be enabled to view this email address)

0 replies

 
  ‹‹ [solved] How to remove Qt 4 SDK!      [solved] Building problems while trying to build Qt 4.7.3 on a machine that has installed Qt 4.4.3 ››

You must log in to post a reply. Not a member yet? Register here!