May 7, 2011

Satmosc Satmosc
Lab Rat
71 posts

Static Qt and debugging helpers

 

ok , now , I have an other issue that due to my poor knowledge , I need help to fix.

When I try to compile my project using Static Qt build (4.7.4), this error occurres :

  1. I compiled Qt using MSVC 2008 as mentioned in earlier post .
  2.    /OUT:release\QGixs.exe @C:\Users\Satmosc\AppData\Local\Temp\QGixs.exe.7032.13495.jom
  3.  
  4. jom 1.0.4 - empower your cores
  5.  
  6. The system cannot find the path specified.
  7. command failed with exit code 1
  8. command failed with exit code 2
  9. The process "C:\QtSDK\Desktop\Qt\4.8\creator\bin\jom.exe" exited with code 2.
  10. Error while building project QGix (target: Desktop)
  11. When executing build step 'Make'

also , as I have compiled the project using -debug-and-release , I expected to build “QML debugging Library” but it fails .just QML Debugging library succeeded and QML Dump and QML Observer fails.
Qt Creator

[EDIT: fixed image link, Volker]

 Signature 

M.Hatami
To the Rationalism

2 replies

May 11, 2011

enamored enamored
Lab Rat
2 posts

Try compile without jom.

May 25, 2011

Satmosc Satmosc
Lab Rat
71 posts

Hi , I found the issue… for all who are interested. Jom makes a binary in the temp files that most of antivirus programs delete them as they detect them as a virus or …. so , by disabling them , it fixes the issue during compile time.

 Signature 

M.Hatami
To the Rationalism

 
  ‹‹ [Moved] Auto completion in Qtcreator with multiple builds      [Solved] QtCreator 2.2 missing quotation mark completion? ››

You must log in to post a reply. Not a member yet? Register here!