July 18, 2010

RafalN RafalN
Lab Rat
1 posts

QFtp example, problem with download


I downloaded Qt 4.6.3 and tried to run QFtp example. After few minutes I’ve found strange problem: I can start downloading a file and if I click cancel on the progress dialog it disappears, but after that, whole file list seems to be “busy” or locked and I can’t even change working directory. Disconnecting and connecting again doesn’t work either.

The problem occurs only when I download files bigger than 10MB. I tried both VS2008 and MinGW4.4 versions of Qt4.6.3.

1 reply

July 18, 2010

harryF harryF
Lab Rat
33 posts

Try to compile your own Qt, and enable the following two defines on top of qftp.cpp (they’re commented out in the default build):

  1. #define QFTPPI_DEBUG
  2. #define QFTPDTP_DEBUG

If there’s nothing obvious that you can see or fix yourself, I suggest to create a bugreport at bugreports.qt.nokia.com, providing the trace you get from the QFTP* debug macros, and as much other information as possible (which ftp server? active or passive mode? binary or ascii?). Also try different FTP servers, maybe that particular ftpd has a bug?


// happy hacking

  ‹‹ Difficulty to show only what I want in QGraphicsview      QScrollArea not showing scrollbars and messing widgets ››

You must log in to post a reply. Not a member yet? Register here!